raito
6441a01ab1
Introduce a data-only module to perform abstraction on the deployment, we use it for WAN for now. The usecase is service discovery for simple cases. Signed-off-by: Raito Bezarius <masterancpp@gmail.com>
22 lines
409 B
Nix
22 lines
409 B
Nix
# This is a data-only module for other modules consumption.
|
|
{ lib, ... }:
|
|
let
|
|
inherit (lib) mkOption types;
|
|
in
|
|
{
|
|
options.bagel.infra.self = {
|
|
wan = {
|
|
family = mkOption {
|
|
type = types.enum [ "inet" "inet6" ];
|
|
default = "inet6";
|
|
};
|
|
address = mkOption {
|
|
type = types.str;
|
|
};
|
|
prefixLength = mkOption {
|
|
type = types.int;
|
|
};
|
|
};
|
|
};
|
|
}
|