raito
dcc5a72db8
This is the third (!) Lix system we are enrolling. Same thing as the build01 one. Signed-off-by: Raito Bezarius <masterancpp@gmail.com>
33 lines
798 B
Nix
33 lines
798 B
Nix
{ ... }: {
|
|
networking.hostName = "build02";
|
|
networking.domain = "aarch64.lix.systems";
|
|
|
|
bagel.hardware.hetzner = {
|
|
enable = true;
|
|
system = "aarch64-linux";
|
|
platformType = "virtual-machine";
|
|
networking.wan = {
|
|
mac = "96:00:03:14:a7:b7";
|
|
address = [ "2a01:4f9:c012:bd6e::1/64" ];
|
|
};
|
|
};
|
|
|
|
# disko will be for another day.
|
|
fileSystems."/" =
|
|
{ device = "/dev/disk/by-uuid/3eda50cf-5866-410f-b948-c246873ab92e";
|
|
fsType = "xfs";
|
|
};
|
|
|
|
fileSystems."/boot" =
|
|
{ device = "/dev/disk/by-uuid/EB58-3EC0";
|
|
fsType = "vfat";
|
|
};
|
|
|
|
swapDevices = [ ];
|
|
|
|
bagel.builders.extra-build-capacity.provider.enable = true;
|
|
i18n.defaultLocale = "en_US.UTF-8";
|
|
system.stateVersion = "24.05";
|
|
deployment.targetHost = "build02.aarch64.lix.systems";
|
|
}
|