floral.systems/flake.nix

28 lines
722 B
Nix

{
inputs = {
nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable";
flake-utils.url = "github:numtide/flake-utils";
petalpkgs.url = "git+https://cl.forkos.org/nixpkgs";
};
outputs = { self, nixpkgs, flake-utils, petalpkgs }:
flake-utils.lib.eachDefaultSystem (system:
let pkgs = import nixpkgs { inherit system; };
in {
# For local development...
devShell = pkgs.mkShell {
LD_LIBRARY_PATH = pkgs.lib.makeLibraryPath [ pkgs.stdenv.cc.cc.lib ];
buildInputs = with pkgs; [ bun ];
shellHook = ''
ln -sf ${petalpkgs.path} .petalpkgs
'';
};
# ... and remote deployment.
# packages = {};
});
}