evolive/pkgs/python/default.nix
raito 9c6d4e5f04 feat: init project
Signed-off-by: Raito Bezarius <masterancpp@gmail.com>
2024-09-03 14:47:36 +02:00

20 lines
392 B
Nix

{ pkgs, python3 }:
let
callPackage = pkgs.lib.callPackageWith (
pkgs // { inherit python3; } // python3.pkgs // python3Packages
);
python3Packages = mkPackages ./.;
mkPackages =
dir:
with builtins;
listToAttrs (
map (name: {
inherit name;
value = callPackage (dir + "/${name}") { };
}) (attrNames (readDir dir))
);
in
python3Packages