forked from lix-project/lix
jade
8497f0fe19
This change feels kind of gross and reveals a fair bit about the
disorganization of our tests, but I think it makes parts of it a bit
better.
Change-Id: Idb8d9a00cbd75d5c156678c6b408b42b59d5e4d7
11 lines
432 B
Nix
Executable file
11 lines
432 B
Nix
Executable file
#! @ENV_PROG@ nix-shell
|
|
#! nix-shell -I nixpkgs=shell.nix --no-substitute
|
|
#! nix-shell --argstr s1 'foo "bar" \baz'"'"'qux' --argstr s2 "foo 'bar' \"\baz" --argstr s3 \foo\ bar\'baz --argstr s4 ''
|
|
#! nix-shell shell.shebang.nix --command true
|
|
{ s1, s2, s3, s4 }:
|
|
assert s1 == ''foo "bar" \baz'qux'';
|
|
assert s2 == "foo 'bar' \"baz";
|
|
assert s3 == "foo bar'baz";
|
|
assert s4 == "";
|
|
(import <nixpkgs> {}).runCommand "nix-shell" {} ""
|