23 lines
767 B
Nix
23 lines
767 B
Nix
{ ... }:
|
|
{
|
|
# jade: this exists because of a Lix bug that has me losing my damn mind and we really cannot debug it without either:
|
|
# * debug logs (infeasible. they are way too spammy)
|
|
# * patching lix (well look where we are)
|
|
#
|
|
# I don't really think it's necessarily appropriate to log at info level when
|
|
# a derivation fails on `main`, so here we have a yolopatch to get the damn
|
|
# thing in the log.
|
|
#
|
|
# I suspect it is a race condition with the garbage collector.
|
|
nixpkgs.overlays = [
|
|
(final: prev: {
|
|
lix = prev.lix.overrideAttrs (old: {
|
|
patches = (old.patches or [ ]) ++ [
|
|
# This patch doesn't apply anymore.
|
|
# ./0001-wip-complain-about-failing-goals-at-warn-level.patch
|
|
];
|
|
});
|
|
})
|
|
];
|
|
}
|