hydra/t/jobs/constituents-broken.nix

20 lines
364 B
Nix

with import ./config.nix;
rec {
constituentA = null;
constituentB = mkDerivation {
name = "empty-dir-B";
builder = ./empty-dir-builder.sh;
};
mixed_aggregate = mkDerivation {
name = "mixed_aggregate";
_hydraAggregate = true;
constituents = [
"constituentA"
constituentB
];
builder = ./empty-dir-builder.sh;
};
}