nix-eval-jobs/tests/assets/ci.nix
adisbladis 516fdc8f6c Add treefmt
And use it in place of editorconfig/nixpkgs-fmt checks
2022-04-26 21:20:24 +12:00

36 lines
666 B
Nix

{ pkgs ? import (builtins.getFlake (toString ./.)).inputs.nixpkgs { }
, system ? pkgs.system
}:
{
builtJob = pkgs.writeText "job1" "job1";
substitutedJob = pkgs.hello;
dontRecurse = {
# This shouldn't build as `recurseForDerivations = true;` is not set
# recurseForDerivations = true;
# This should not build
drvB = derivation {
inherit system;
name = "drvA";
builder = ":";
};
};
recurse = {
# This should build
recurseForDerivations = true;
# This should not build
drvB = derivation {
inherit system;
name = "drvB";
builder = ":";
};
};
"dotted.attr" = pkgs.hello;
}