30dcc19d1f
I think it is bad for these reasons when `tests/` contains a mix of functional and integration tests - Concepts is harder to understand, the documentation makes a good unit vs functional vs integration distinction, but when the integration tests are just two subdirs within `tests/` this is not clear. - Source filtering in the `flake.nix` is more complex. We need to filter out some of the dirs from `tests/`, rather than simply pick the dirs we want and take all of them. This is a good sign the structure of what we are trying to do is not matching the structure of the files. With this change we have a clean: ```shell-session $ git show 'HEAD:tests' tree HEAD:tests functional/ installer/ nixos/ ``` (cherry picked from commit 68c81c737571794f7246db53fb4774e94fcf4b7e)
17 lines
346 B
Nix
17 lines
346 B
Nix
let
|
|
|
|
f = args@{x, y, z}: x + args.y + z;
|
|
|
|
g = {x, y, z}@args: f args;
|
|
|
|
h = {x ? "d", y ? x, z ? args.x}@args: x + y + z;
|
|
|
|
j = {x, y, z, ...}: x + y + z;
|
|
|
|
in
|
|
f {x = "a"; y = "b"; z = "c";} +
|
|
g {x = "x"; y = "y"; z = "z";} +
|
|
h {x = "D";} +
|
|
h {x = "D"; y = "E"; z = "F";} +
|
|
j {x = "i"; y = "j"; z = "k"; bla = "bla"; foo = "bar";}
|