hydra/t/jobs/basic.nix
Maximilian Bosch fd765bc97a
Fix "My Jobs" tab in user dashboard
Nowadays `Builds` doesn't reference `Project` directly anymore. This
means that simply resolving both `jobset` and `project` with a single
JOIN from `Builds` doesn't work anymore. Instead we need to resolve the
relation to `jobset` first and then the relation to `project`.

For similar fixes see e.g. c7c4759600.
2022-11-22 20:54:51 +01:00

23 lines
446 B
Nix

with import ./config.nix;
{
empty_dir =
mkDerivation {
name = "empty-dir";
builder = ./empty-dir-builder.sh;
meta.maintainers = [ "alice@invalid.org" ];
meta.outPath = "${placeholder "out"}";
};
fails =
mkDerivation {
name = "fails";
builder = ./fail.sh;
};
succeed_with_failed =
mkDerivation {
name = "succeed-with-failed";
builder = ./succeed-with-failed.sh;
};
}