hydra/t/jobs/aggregate.nix
Graham Christensen c60c8d10ea add api endpoint: /build/<id>/constituents
Returns a list of constituent builds
2021-09-24 16:30:44 -04:00

27 lines
470 B
Nix

with import ./config.nix;
{
a =
mkDerivation {
name = "empty-dir-a";
builder = ./empty-dir-builder.sh;
};
b =
mkDerivation {
name = "empty-dir-b";
builder = ./empty-dir-builder.sh;
};
aggregate =
mkDerivation {
name = "aggregate";
builder = ./empty-dir-builder.sh; # doesn't matter, just needs to pass a build
_hydraAggregate = true;
constituents = [
"a"
"b"
];
};
}