buildbot-nix/nix/profiler-plugin.nix
raito 0ffae5766b feat: add buildbot-profiler
This enable the possibility to run buildbot-profiler on a production
system.

This exposes the UI but does not compile properly the JavaScript assets
yet.

Signed-off-by: Raito Bezarius <raito@lix.systems>
2024-10-22 17:13:19 +02:00

37 lines
694 B
Nix

{
lib,
buildPythonPackage,
fetchFromGitHub,
setuptools,
wheel,
}:
buildPythonPackage rec {
pname = "buildbot-profiler";
version = "1.2.2";
pyproject = true;
src = fetchFromGitHub {
owner = "tardyp";
repo = "buildbot_profiler";
rev = "v${version}";
hash = "sha256-r56Cze0v3gKWKJwRy0BUYz5z8d0g3jerCIu3KreNxUc=";
};
build-system = [
setuptools
wheel
];
pythonImportsCheck = [
"buildbot_profiler"
];
meta = {
description = "";
homepage = "https://github.com/tardyp/buildbot_profiler";
license = lib.licenses.unfree; # FIXME: nix-init did not find a license
maintainers = with lib.maintainers; [ raitobezarius ];
};
}