raito-shared-public-infra/modules/android-cache.nix
Raito Bezarius 6c0d19e005 epyc: disable all android cache for now
Signed-off-by: Raito Bezarius <masterancpp@gmail.com>
2024-03-04 00:59:21 +01:00

15 lines
493 B
Nix

{ lib, ... }:
let
mirrors = {
# "https://android.googlesource.com" = "/mnt/aospaosp/mirror";
# "https://github.com/LineageOS" = "/var/lib/src/lineageos/LineageOS";
# "https://github.com/TheMuppets" = "/var/lib/src/themuppets/TheMuppets";
};
in
{
nix.envVars.ROBOTNIX_GIT_MIRRORS = lib.concatStringsSep "|" (lib.mapAttrsToList (local: remote: "${local}=${remote}") mirrors);
# Also add local mirrors to nix sandbox exceptions
nix.sandboxPaths = lib.attrValues mirrors;
}