raito-shared-public-infra/modules/packages.nix
Raito Bezarius 1b1c6b2849 feat: cleanup post btrfs epic crash
BTRFS had a bug and we know how it goes.

Signed-off-by: Raito Bezarius <masterancpp@gmail.com>
2024-07-04 21:25:14 +02:00

41 lines
662 B
Nix

{ pkgs, inputs, ... }: {
# this extends the list from:
# https://github.com/numtide/srvos/blob/master/server.nix#L10
environment.systemPackages = with pkgs; [
socat
whois
nix-output-monitor
jq
psmisc
libarchive
sipcalc
iperf
openssl
binutils
file
wget
htop
ripgrep
lsof
tcpdump
rsync
git
tig
lazygit
python3
iotop
man-pages
netcat
mtr
(neovim.override { vimAlias = true; })
pciutils
ethtool
usbutils
ipmitool
# tries to default to soft-float due to out-dated cc-rs
] ++ lib.optional (!stdenv.hostPlatform.isRiscV) bandwhich;
}