infra/common/admins.nix
raito 130faa2836 feat: finer-grained ACLs for server accesses
In the process of adding multi-tenant infrastructure, it seems relevant
to add finer-grained ACLs.

Signed-off-by: Raito Bezarius <masterancpp@gmail.com>
2024-08-01 23:45:37 +02:00

22 lines
322 B
Nix

{ lib, ... }:
let
inherit (lib) genAttrs;
buildInfraMembers = [
"delroth"
"emilylange"
"hexchen"
"jade"
"janik"
"k900"
"maxine"
"raito"
"thubrecht"
"yuka"
];
in
{
bagel.admins.users = genAttrs buildInfraMembers (username: {
groups = [ "build-infra" ];
});
}