forked from lix-project/nixos-module
jade
1d636fd90a
Problem caused by: https://gerrit.lix.systems/c/lix/+/993 But this is actually nixpkgs doing extremely silly feature detection of Nix based on version which it should /absolutely not be doing/.
18 lines
343 B
Nix
18 lines
343 B
Nix
{ nixos, lix-module }:
|
|
let
|
|
configs = {
|
|
it-builds = nixos ({ ... }: {
|
|
documentation.enable = false;
|
|
fileSystems."/".device = "ignore-root-device";
|
|
boot.loader.grub.enable = false;
|
|
system.stateVersion = "24.05";
|
|
});
|
|
|
|
};
|
|
in
|
|
{
|
|
inherit configs;
|
|
|
|
it-builds = configs.it-builds.config.system.build.toplevel;
|
|
}
|